戻る

セキュリティ

目次


暗号化

盗聴リスクと暗号化

暗号の種類

暗号とは情報を「特定の条件が整った場合のみ復元可能な一定の規則で変換」して一見意味のない文字列や図案とするものである

鍵の分類

語彙

単語説明備考
初期ベクトル(IV)初回の暗号化で直前おブロックの暗号の代わりとなる
鍵ストリーム
トップへ戻る

認証システム

認証システムの基本的な考え方

パスワード認証

種類

パスワード認証の運用上の注意点

バイオメトリクス認証

シングルサインオン(SSO:Single Sign On)

  1. Cookieによる認証
  2. リバースプロキシによる認証

認証と認可のプロトコル

トップへ戻る

デジタル署名

デジタル署名の基本的な考え方

なりすましと改ざんへの対策

メッセージダイジェスト

メッセージダイジェスト、ハッシュ関数の種類

PKI(Public Key Infrastructure)

トップへ戻る

マルウェア

コンピュータウイルスとマルウェア

マルウェアの分類

コンピュータウイルスの3機能

ルートキット

マルウェアへの対策

マルウェア観戦後の対応

  1. 感染したシステムの利用停止
  2. ユーザへのアナウンス
  3. マルウェアと影響範囲の特定
  4. 復旧手順の確立と復旧作業
  5. 原因の特定と対応策の策定
  6. 関係機関への届け出

CVSS

共通脆弱性評価システム(CVSS:Common Vulnerability Scoring System)

CVSSの3つの基準

  1. 基本評価基準:脆弱性の特性を評価する
  2. 現状評価基準:脆弱性の現在の深刻度を評価する
  3. 環境評価基準:最終的な脆弱性の深刻度を評価する
トップへ戻る

サイバー攻撃

クロスサイトスクリプティング

Reflected XSS

Stored XSS

DOM Based XSS

インジェクション攻撃

SQLインジェクション

HTTPヘッダインジェクション

OSコマンドインジェクション

DoS攻撃(Denial of Service)

DNS amplification(DNSamp,DNS増幅攻撃)

ICMP Flood(Ping Flood)

TCP SYN Flood

リフレクタ攻撃(反射型攻撃、RDoS)

バッファオーバフロー

スタック攻撃

ヒープ攻撃


対策

その他の攻撃手法

トップへ戻る

LANにおけるセキュリティ対策技術

ファイアウォール

DMZ(DeMilitarized Zone)

パーソナルファイアウォール

その他対策技術

IDS(Intrusion Detection System)

パケットフィルタリングなどで検出が困難な攻撃に対処するためのシステム


シグネチャ:攻撃パターンのデータベースで、パターンに合致する兆候を通告したりねっと遮断する



トップへ戻る

ユーザ認証におけるセキュリティ対策技術

PPP(Point to Point Protocol)

NCP(Network Control protocol)

IPCP(Internet Protocol Control Protocol)

IPと接続する場合にNCPとしてIPの設定をネゴシエーションする

LCP(Link Control Protocol)

LCPネゴシエーションのプロセス
  1. →Request(MRU1500,CHAP認証)
  2. ←Request(CHAPサポート外)
  3. →Request(MRU1500,PAP認証)
  4. ←ACK(OK)

MRU(Maximum Receive Unit)

PPPoE(PPP over Ethernet)[RFC2516]

認証技術

PAP(Password Authentication Protocol)

CHAP(Challenge Handshake Authentication Protocol)

EAP(PPP Extensible Authentication Protocol)

※セキュリティ上はCHAPを選択し、LCPネゴシエーションでPAPを要求された場合は拒否する設定を推奨する

RADIUS(Remote Authentication Dial-In User Service)[RFC2138]

DIAMETER

Kerberos(Kerberos Ver.5)[RFC1510]

レルム

KDC(Key Distribution Center)

※プリンシパル:レルム内においてKDCに管理されるすべてのノードのこと

認証プロセス
  1. プリンシパルがASにチケットを要求
  2. ASはKDBを検索し、正当なプリンシパルなら共通鍵で暗号化したチケットを返信
  3. プリンシパルはチケットをTGSに送信し、サーバの仕様許可証を要求する
  4. TGSはサーバ使用許可証とサーバ通信に使う共通鍵を返信
  5. サーバと通信を開始

SSL/TLS

SSL→2014年 POODLE攻撃(脆弱性発覚)→RFC提案→TLS[RFC2246]

TLSでできること

サーバ証明書

TLSの通信手順

  1. ハンドシェイク
    1. サーバを認証する
    2. 暗号化アルゴリズムを決める
    3. 暗号化鍵とMAC鍵を作る
  2. データの伝送

言葉

言葉意味
前方秘匿性(Forward secrecy)漏洩以前に行われた暗号通信が不正に複合されないことを保証する

VPN

種類

VPNの基本構成

VPNの2つのモード

※「VPNゲートウェイ」=「セキュリティゲートウェイ」→IPsecを使うもの「IPsecゲートウェイ」

VPNを実現するプロトコル

IPsec

IPsecのフレーム構造

PPTP(Point to Point Tunneling Protocol)[RFC2637]

L2TP[RFC2661]

トップへ戻る

高境界線におけるセキュリティ対策技術

トップへ戻る

セキュリティ関連規格

CC

ISMS


ISMSを構築する手順

  1. ISMSの範囲を定義する
  2. ISMSの基本方針を策定する
  3. リスクアセスメントの体系的な取り組み方法を策定する
  4. リスクを特定する
  5. リスクアセスメントを実施し、リスクを分析・評価する
  6. リスクのための選択肢を特定し、評価する
  7. リスクに対応した管理目的および管理策を選択する
  8. 経営陣から残留リスクの承認を得る
  9. 経営陣からISMS導入および運用の許可を得る
  10. 適用宣言書を作成する

用語

言葉説明
リスク一般的にリスク=危険だが、リスクが高い(=見返りも大きい)場合があるように、リスクには「不確実性」という意味もある。
フォレンジックス情報システムの状態や利用履歴を記録し、公的な証拠能力を担保する水準で保管すること、もしくはそのシステム自体を指す用語。従来のシステムログのような狭義のログだけでなく、広義では業務活動全般のログが収集対象となる。

JIS Q 31000シリーズ

リスクマネジメントのやり方はJIS Q 31000シリーズで標準化されている。JIS Q 27000シリーズに基づいてセキュリティマネジメントシステムを構築していくと、リスクマネジメントの実施に直面するが、両者は整合性を保つように設計されている。

その他のセキュリティ関連規格

セキュリティ関連組織

CSIRT

内閣サイバーセキュリティセンター

トップへ戻る